Início > Excel > Excel – Calcular EAN-13, dígito verificador

Excel – Calcular EAN-13, dígito verificador

Esse é mais um exemplo, dos diversos encontrados na internet, para calcular o dígito verificador do EAN-13.

O destaque fica para o exemplo pronto em Excel.

image

 

Outra dica é a calculadora para UPC/EAN/SCC/SSCC

 

Fonte: eHow, Morovia Library: Especificações EAN-13

Categorias:Excel Tags:
  1. 2 de junho de 2015 às 10:39

    Muito boa a explicação da fórmula do código EAN13

  2. Marcelo
    31 de março de 2016 às 8:54

    1 – Cálculo: Abra o excel, coloque o EAN13 sem DV (12 posições) na célula A1. Cole a fórmula abaixo na célula A2 e então terá o DV EAN13 na célula A2. 
    =DIREITA(10-(MOD((DIREITA(ESQUERDA(A1;1);1)*1)+(DIREITA(ESQUERDA(A1;2);1)*3)+(DIREITA(ESQUERDA(A1;3);1)*1)+(DIREITA(ESQUERDA(A1;4);1)*3)+(DIREITA(ESQUERDA(A1;5);1)*1)+(DIREITA(ESQUERDA(A1;6);1)*3)+(DIREITA(ESQUERDA(A1;7);1)*1)+(DIREITA(ESQUERDA(A1;8);1)*3)+(DIREITA(ESQUERDA(A1;9);1)*1)+(DIREITA(ESQUERDA(A1;10);1)*3)+(DIREITA(ESQUERDA(A1;11);1)*1)+(DIREITA(ESQUERDA(A1;12);1)*3);10));1)

    2 – Validação do DV de um EAN13: Abra o excel, coloque o EAN13 já com DV na célula A1. Cole a fórmula abaixo na célula A2 e então terá a validação do mesmo.
    =SE(A1=””;””;SE(NÚM.CARACT(A1)13;”MAIOR QUE 13″;SE(DIREITA(A1;1)=DIREITA(10-(MOD((DIREITA(ESQUERDA(A1;1);1)*1)+(DIREITA(ESQUERDA(A1;2);1)*3)+(DIREITA(ESQUERDA(A1;3);1)*1)+(DIREITA(ESQUERDA(A1;4);1)*3)+(DIREITA(ESQUERDA(A1;5);1)*1)+(DIREITA(ESQUERDA(A1;6);1)*3)+(DIREITA(ESQUERDA(A1;7);1)*1)+(DIREITA(ESQUERDA(A1;8);1)*3)+(DIREITA(ESQUERDA(A1;9);1)*1)+(DIREITA(ESQUERDA(A1;10);1)*3)+(DIREITA(ESQUERDA(A1;11);1)*1)+(DIREITA(ESQUERDA(A1;12);1)*3);10));1);”CORRETO”;”INCORRETO!”))))

  3. LEONARDO SANT ANA
    6 de setembro de 2017 às 16:59

    Agradeço muito esta fórmula, me resolveu um grande problema

  1. No trackbacks yet.

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: